opening AML screen with many alarms (including subprojects) causes a freeze

opening AML screen with many alarms (including subprojects) causes a freeze

Description

When opening an AML screen with very many entries, the system freezes.

Cause:

In this case, the alarm ring buffer contains a very large number of alarms (several tens of thousands). If they are no longer active when the Service Engine is restarted, these alarms are removed from alarm.bin. For this purpose, these alarms are searched in all open AML screens and then marked as removed. If an AML screen contains a very large number of open alarms, this search takes a very long time.

Solution:

The procedure for updating the AML/CEL has been changed. The search has been optimized. The system no longer freezes even with a very large number of alarms.

To benefit from this fix:

  • Update your zenon Software Platform to the latest build of zenon 11 or higher.

 



Item ID: 256385
Version: 11.00 Build: 115310